Insulation Tests On Old Components?

Topics relating to lighting control gear, including magnetic & high frequency ballast and ancilliary devices such as starters, ignitors and switchgear.
Post Reply
User avatar
Tom
ATL Admin
Posts: 887
Joined: Mon Jan 03, 2011 5:39 pm
Favourite Manufacturer: Pre 1993 Thorn
Area of interest: Fluorescent and Discharge Lighting
Oldest item: One of a few pip top lamps!
Location: Oxfordshire
Contact:

Insulation Tests On Old Components?

Post by Tom » Fri May 02, 2014 4:12 pm

Out of interest, has anyone performed high voltage 'Megger' or flash tests on any of these lovely old ballasts etc? I'd like to think they'd pass with flying colours! I don't own a suitable tester so would be interested to know...
I LOVE LAMP!

User avatar
Kev
Posts: 1180
Joined: Wed Jan 05, 2011 10:32 pm
Favourite Manufacturer: Atlas and CourtneyPope
Area of interest: Discharge and Fluorescent
Location: Cornwall

Re: Insulation Tests On Old Components?

Post by Kev » Fri May 02, 2014 10:06 pm

I have a megga but have never tested any vintage fittings! I know HF ballasts don't like it much lol esp 1000v

User avatar
Tom
ATL Admin
Posts: 887
Joined: Mon Jan 03, 2011 5:39 pm
Favourite Manufacturer: Pre 1993 Thorn
Area of interest: Fluorescent and Discharge Lighting
Oldest item: One of a few pip top lamps!
Location: Oxfordshire
Contact:

Re: Insulation Tests On Old Components?

Post by Tom » Fri May 02, 2014 10:42 pm

Haha I wouldn't dare megger anything HF LOL. Remember the warnings inside Thorn fittings with Vivatronic starters stating tubes should be removed before testing?
I LOVE LAMP!

Post Reply